Focus RS Forum banner
1 - 14 of 14 Posts

·
Premium Member
Joined
·
1,498 Posts
Is your reversing light working Tina? I had similar issue and mine was diagnosed as reverse switch on gearbox. I believe it a fairly common fault. Fortunately done within warranty period. Hope you get it sorted.
 

·
Premium Member
Joined
·
23,436 Posts
Yep, as Richard says, it'll be your reverse light Tina, i noticed it wasn't working last week at the Toby & forgot to mention it to you later in the day! :facepalm:

I then forgot again to mention it to you again at Keiths yesterday!! :facepalm: :blush:
 

·
Premium Member
Joined
·
5,417 Posts
Discussion Starter · #5 ·
Yep, as Richard says, it'll be your reverse light Tina, i noticed it wasn't working last week at the Toby & forgot to mention it to you later in the day! :facepalm:

I then forgot again to mention it to you again at Keiths yesterday!! :facepalm: :blush:
aah right

So do I need a new bulb? will that cure it :smile: or is it something else

Yep. Time you placed an order for the mk3... :eekout:

:nice:
Oh Derek I don't think so! Our order goes to the mustang :smile:
 

·
Premium Member
Alb (Mk2 MP350)
Joined
·
3,051 Posts
The switch is a common failure point.
You would also notice that your rear wiper doesn't operate when the fronts are on and you select reverse.
 

·
Registered
Joined
·
1,192 Posts
Reverse switch

Very common problem

Replaced mine a few weeks ago, bought the part off ebay for about £13 and took me about 40 minutes to do
 
1 - 14 of 14 Posts
Top