Focus RS Forum banner
21 - 27 of 27 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #23 ·
Jas had exactly the same fault with an AP clutch...now that was sage
oh dear, that is not good to hear, I have a receipt showing that a previous owner had the AP kit fitted to what is now my car, work done by SCC / St Albans Car Clinic way back in 2013.

Have found a few old conversations about AP clutches, not many were positive, but then bad experiences get shared more

Who is Jas, would be nice to contact and sk a question or two and share my issue........

:)
 

·
Forum midget
Joined
·
4,774 Posts
oh dear, that is not good to hear, I have a receipt showing that a previous owner had the AP kit fitted to what is now my car, work done by SCC / St Albans Car Clinic way back in 2013.

Have found a few old conversations about AP clutches, not many were positive, but then bad experiences get shared more

Who is Jas, would be nice to contact and sk a question or two and share my issue........

:)
Jas is on here, surprised he hasn't replied. He's got another Mk2 now but is more posting about his ST170.

Anyway he went big power and the standard clutch couldn't cope, so he went down the AP route, he had gear engagement issue straight away I think and they tried two or three replacements and it's a long time ago I'm not sure if it was fully resolved before he reverted the car back to standard and moved it on.

There was a massive thread on here about it at the time.
 

·
Registered
Joined
·
18,009 Posts
Have you checked all the linkages

I know it’s not the same but my old transit had a particular problem on the linkage and it would seize because water would fall directly on it
 
21 - 27 of 27 Posts
Top