Focus RS Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
108 Posts
Finished installing the new intercooler and hard pipe kit today. :nice:

Started her up, all ran fine, so put everything back together and rolled out the garage for a test run.

200 yards down the road, it all goes wrong, pops, bangs and then she died. :cry:

Turns out the pipe from the intercooler to the new hard pipe on the cold side had slipped off.

Annoyingly it's the one with the jubilee clips which I can't reach without taking all the underside off again! Typical. :thud:

Looks like next Saturday is now planned.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #4 ·
It's a Pro Alloy! :nice:

The kit looks like it fits together quite easily, it is only pipes and clips after all, but I think there is a slight design flaw in the length of silicon pipe from the inter cooler to the hard pipe.

The AS kit comes with a longer pipe, which has what can only be described as a wiggle it, although a smaller hard pipe. Don't know if that kits has the same problem, but clearly AS saw there was an issue in this area.

An inch more silicon pipe and I don't think there would be an issue with the Pro Kit.
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #9 ·
The car needs a service soon, so I will get the garage to have a look at it.

I needed the car back on the road, so couldn't spare any more time on it, I think I was up to 5 hours when I threw in the towel.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top