Focus RS Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter · #1 ·
Got in the car this morning set the heater at 24 degrees, drove 20 miles to work with it blowing just cold air out. Got in the car tonight blowing cold air again, then suddenly started blowing warm air after I had switched it off for a few minutes. Anyone come across this issue. Cheers Kev
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #4 ·
Thanks fellas, its well down. Had this problem last year losing coolant, but it resolved itself. Cars not moved for a couple of weeks been on holiday. Is it a common issue using a lot of coolant with the RS
 

·
Super Moderator
BMW 1M
Joined
·
10,879 Posts
Have a search for radiator leaks and you'll see it's a common issue.

I'd be more concerned you haven't damaged the engine TBH, rather than feeling a little cool.

Please get your coolant/radiator checked ASAP.
 

·
Super Moderator
BMW 1M
Joined
·
10,879 Posts
To be fair you'd probably know if you'd cooked the engine, so don't worry too much if it drives ok.

You'll have to treat it as a (second) warning and get the coolant loss issue sorted ASAP, otherwise it'll be big bill time.

If you have a litle search, the classic radiator leakage sign is a wet sponge underneath the rad.
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #12 ·
Car now fixed. Does anyone know if the new radiator just purchased was improved by Ford. Or is it the exact same part. You can see the problem immediately you have too composite materials forming a seal. No doubt they shrink & expand at varying rates. the bottom right hand side had totally gone in the corner.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top