Focus RS Forum banner
61 - 80 of 119 Posts

· Registered
Joined
·
2,374 Posts
Oct. '16 5.5k miles The common drive mode unavailable problem about 3 or 4 times - cures itself, all sound from the speakers went and I mean all - even the fake engine sound! Checked all relevant fuses - all ok left it for a few hours and it came back all by itself. A few months ago there was a massive hissing sound from the speakers, again it eventually cured itself!

So, nothing to take it back to the dealer for just a couple of niggling and annoying things which I hope, won't return. Just waiting for the recall letter, now.

Would I recommend one? Yes, without a doubt but only a post July '17 or one that's already had the gasket fix.

JohnD
 

· Registered
Joined
·
475 Posts
16plate with 4700 miles (car share half the week so only do 4k a year at the most and picked it up from a person who kept it garaged at 2k miles a year old)

HG replacement but no issues as such, I had a bit of a rough idle once and the drive mode not available once.

Aside from that since the HG recall replacement Ive had nothing but a tyre deflation issue which was a valve replacement.

I love the car and have spent a little on it so far; FPM 375, valveless Mountune Exhaust, upgraded mounts and PTU. I Plan to spend countless more on the car and keep it for many years to come 😃

Its a pleasure to drive, clean and admire 😬 best car Ive owned and I dont regret buying it even when I knew about the engine issues i still bought it.
 

· Registered
Joined
·
687 Posts
March 2016 build, 11000 miles only issue I've had is a failed head lamp (replaced on warranty). The engine issue concerns me slightly but I've not had a single problem, it runs perfectly.

It's an awesome car, super quick with an epic AWD system, why wouldn't you get one?
 

· Registered
Joined
·
6 Posts
Just over a year and 19000 miles and no major issues - just the occasional drive mode not available and the touch screen going completely dead ( with no functionality at all). Still puts a huge smile on my face every time I drive it!
 

· Registered
FW MK2 JWR100. FW MK3 FPM375
Joined
·
1,302 Posts
Superb car loved every 367 days of it.

15K and it's not missed a beat and tbh with all the hype of the engine issues I thought if it's going to blow then I'm going to rag the :censored: off it as it's covered under warranty and the more I've ragged it the better it's got.

Thumbs up for the RS from me.
😂😂👍
 

· Captain Slow
Joined
·
3,556 Posts
I've had mine since January last year; it's a Nov 16 build and, with the exception of the intermittent driving mode thing which everyone has now and again, it's been faultless and I've enjoyed every single one of my 10000 miles.

Even passed its pressure test the other week with flying colours so just a new gasket for me.
 

· Registered
Joined
·
79 Posts
October 2016 with FPM375 5000 miles.

Two minor rattles,both fixed. Other than that, perfection.

Most fun car I've ever owned.

Great to see a thread that is so positive on this forum, instead of the usual doom and gloom!
 

· Registered
Joined
·
79 Posts
Had my fpm375 for 18 months since new, and done 15k hard miles in it.

It had the boot lock pop open several times a week for several months until Ford finally found the fault. The under tray has been ripped off by 2 inches of snow. The Bluetooth regularly disconnects from my phone. There are several rattles developing in the cabin. The "mode selection not available" occurs every few weeks. Oh and last week the adaptive headlights went cross-eyed on me and wouldn't aim at the road....... but I still love the car!! :)
Slight update to the above. Just leaving work an my brakes failed! Luckily it was just a speed hump I hit at full speed, and not another car or junction. That was a bad experience!

Pressed the brake and got nothing. Pressed them again, then pumped them, and still nothing. Brakes came back just after that. Can brakes freeze???
 

· Registered
Joined
·
976 Posts
13 months old and 7500 miles and no probs at all apart from wonky fuel filler flap which was sorted and required a new cylinder head at first service but no symptoms and only topped up coolant a smidge once in years ownership. Running M400 and car seems quicker, freeer revving and louder everyday :)
 
61 - 80 of 119 Posts
Top