Focus RS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
After years of finger pricking to test blood glucose I have finally been accepted on a six month evaluation to see if I improve control, with a view to N H S providing funding to cover the cost of the sensors. Have completed the Libre academy, sat in on a live webinar, received first sensor which I have attached to my arm. ABBOTT U S pharma that produce the product no longer supply the reader, you have to use your smart phone to scan the sensor. I have an I Phone 7 Plus , which is the minimum required to collect data. My phone will not activate the sensor it has latest IOS 15.3.3088 which I downloaded recently. Libre Link 2 software full version was installed at same time on the phone . Any one using Libre 2 experience similar issues. Thanks.
 

·
Registered
William-RS Mk3
Joined
·
695 Posts
My wife has been using the Libre 1 and then 2 sensors for several years now. We use the app on Samsung smartphones and have very few problems although we have more Libre 2 sensor failures then we had with the Libre 1 sensors. The same sensors in the USA are only rated for 10 days use not 2 weeks as in the UK. I have never been able to find out why. When the NHS agreed to provide the sensors, I used to buy then for her, they also provided the Libre reader but we prefer the smartphone so only use it for finger ***** tests.
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #3 ·
My wife has been using the Libre 1 and then 2 sensors for several years now. We use the app on Samsung smartphones and have very few problems although we have more Libre 2 sensor failures then we had with the Libre 1 sensors. The same sensors in the USA are only rated for 10 days use not 2 weeks as in the UK. I have never been able to find out why. When the NHS agreed to provide the sensors, I used to buy then for her, they also provided the Libre reader but we prefer the smartphone so only use it for finger * tests.
Thanks for the reply Vorgem .
 

·
Registered
Joined
·
1 Posts
Worthless garbage. Received my 90 day supply. The first sensor failed within three hours. The second sensor lasted the full 14 days. The next sensor never started and failed. I've just put my fourth sensor on and I'm hoping it actually starts in the next hour. This happened with my previous 90 day supply. The failure rate for me is in excess of 30%. Now again, tomorrow I have to sit on the phone with Abbott support and go through the endless same questions I have answered each of times I have had a failure in order to get a replacement. I think I'm done. When this 90 da u supply is done, I think I'll go back to a finger stick. At least they don't fail and cause me to sit on the phone with customer service. STAY AWAY FROM THESE GARBAGE DEVICES!
 

·
Registered
Joined
·
96 Posts
Discussion Starter · #5 ·
thanks for your reply my first 3 sensors worked fine for the full 14 days, however the latest 2 were failures the first one worked for 4 days and failed the next day" displaying a message sensor stopped working attach a new one " The next one fell off my arm within an hour of it being applied. Ringing Abbott customer care line proved to be a learning experience I hope not to have to repeat to often.
 
1 - 5 of 5 Posts
Top