Focus RS Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
9,233 Posts
Discussion Starter · #1 ·
Has anyone owned one of these? And can you remember if the centre caps seemed loose and spun round?
After a quick search on google there are a few threads over the years on various forums about it and it seems the norm but it just seems odd to me and doesn't look or seem right
 

·
Registered
Joined
·
5,062 Posts
I've had two ,I dont remember the caps spinning but it was a long time ago , they come with a little tool for pulling the caps off which I still have i use it on the wifes car , it's like a T shape with a hook on the end that fits under the cap, if I remember rightly they are a bit flimsy .
 

·
Registered
Joined
·
3,476 Posts
I've had two ,I dont remember the caps spinning but it was a long time ago , they come with a little tool for pulling the caps off which I still have i use it on the wifes car , it's like a T shape with a hook on the end that fits under the cap, if I remember rightly they are a bit flimsy .
The same tool was used on Mondeo ST220 alloys. Never found it to be flimsy, just hook it under the edge of the cap and pull. Although I have known some people to try to prise the cap off with it, where the tool is just likely to bend.
 

·
Registered
Joined
·
9,233 Posts
Discussion Starter · #7 ·
I've had two ,I dont remember the caps spinning but it was a long time ago , they come with a little tool for pulling the caps off which I still have i use it on the wifes car , it's like a T shape with a hook on the end that fits under the cap, if I remember rightly they are a bit flimsy .
Mine didn't come with the tool but ive ordered a new one from ford
 

·
Registered
Joined
·
9,233 Posts
Discussion Starter · #15 ·
Got the standard exhaust back on.

The climate control isn't working as it should, any temperature set it blows cool air only, if the setting is at Hi it blows hot air but only at the Hi setting any other number it reverts back to cool air even at 30°C which is a pain, one tech i spoke to said it will be the control panel but obviously new parts for these are a no go, there are a few used ones on ebay but could end up urinating into the wind with those, any past owners had this problem and was it indeed the control panel?
 

·
Registered
Joined
·
2,860 Posts
Sorry cant help on that i didnt have the posh one with the climate control only the ac

have you posted any photos of thie car? I had mine for about 8 years, always felt it was a little underpowered but other than that a great car
 

·
Registered
Joined
·
18,009 Posts
Are you on the st170 owners site
They may know

You can map it to 180 lol or find a
T-one 90 or T-two20


oh take a punt on a panel, or find some one who can test it
No other options really
 
1 - 17 of 17 Posts
Top